Halloween Party code in C#

Alex is attending a Halloween party with his girlfriend, Silvia. At the party, Silvia spots the corner of an infinite chocolate bar (two dimensional, infinitely long in width and length).

If the chocolate can be served as only 1 x 1 sized pieces and Alex can cut the chocolate bar exactly K times, what is the maximum number of chocolate pieces Alex can cut and give Silvia?

Input Format
The first line contains an integer T, the number of test cases. T lines follow.
Each line contains an integer K.

Output Format
T lines; each line should contain an integer that denotes the maximum number of pieces that can be obtained for each test case.

Constraints
1T10
2K107

Note: Chocolate must be served in 1 x 1 sized pieces. Alex can’t relocate any of the pieces, nor can he place any piece on top of another.

Sample Input #00

4
5
6
7
8

Sample Output #00

6
9
12
16

class Halloween_Party_Hackerrank
    {
        static void Main(string[] args)
        {
            Int64 T = Convert.ToInt32(Console.ReadLine());
            Int64 result = 0;
            for (Int64 i = 0; i < T; ++i)
            {
                Int64 k = Convert.ToInt32(Console.ReadLine());
                if (k % 2 == 0)
                {
                    result = (k / 2) * (k / 2);
                }
                else
                {
                    result = ((k / 2) + 1) * (k / 2);
                }
                Console.WriteLine(result);
            }
            Console.ReadKey();
        }
    }

Leave a comment